
Chapter 2 – Working Knowledge of Computer System

Introduction to the operating system

An Operating System (OS) is an interface between a computer user and computer hardware. An operating
system is a software which performs all the basic tasks like file management, memory management,
process management, handling input and output, and controlling peripheral devices such as disk drives
and printers.

It is a program with following features:
 An OS is a program that acts as an interface between the software and the computer hardware.
 It is an integrated set of specialised programs that are used to manage overall resources and

operations of the computer.
 It is specialised software that controls and monitors the execution of all other programs that

reside in the computer, including application programs and other system software.

Objectives of Operating System
 To make a computer system convenient to use in an efficient manner
 To hide the details of the hardware resources from the users
 To provide users a convenient interface to use the computer system
 To act as an intermediary between the hardware and its users and making it easier for the users to

access and use other resources
 To manage the resources of a computer system
 To keep track of who is using which resource, granting resource requests, according for resource

using and mediating conflicting requests from different programs and users

Characteristics / Functions of Operating System:

 Memory Management -- keeps tracks of primary memory i.e. what part
of it is in use by whom, what part is not in use etc. and allocates the
memory when a process or program requests it.

 Processor Management -- allocates the processor (CPU) to a process
and de-allocates processor when it is no longer required.

 Device Management -- keeps track of all devices. This is also called I/O
controller that decides which process gets the device, when, and for
how much time.

 File Management -- allocates and de-allocates the resources and
decides who gets the resources.

 Security -- prevents unauthorized access to programs and data by
means of passwords and similar other techniques.

 Job accounting -- keeps track of time and resources used by various jobs
and/or users.

 Control over system performance -- records delays between request for a service and the system.
 Interaction with the operators -- The interaction take place via the console of the computer in the

form of instructions. OS does the corresponding action and informs operation by a display screen
 Error-detecting aids -- Production of dumps, traces, error messages and other debugging and

error-detecting methods.
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Types of Operating Systems

 Batch Operating System: It is one of the oldest method used to run the programs.Few years back
to perform a simple calculation computer takes days and weeks of time.So the users used to
prepare their job and it is in the form of punched cards then this batch of programs are loaded
into the computer by the computer operator and they get executed one by one, It is a very slow
process and when the program is getting executed no one can interrupt.Turn around time is large
and the job can enter an infinite loop.

 Real Time Operating System: In this type of operating system job has to be completed within the
set time limit otherwise the job gets lost or looses its meaning.This system is totally time
dependent. This os is mainly used in Flight controllers,robotics,fuel injection system etc.

 Network Operating System: A network operating system (NOS) is software that just controls the
network and transfers packets over the network.It provides certain features for the safe delivery
of messages over internet. OSI reference model have 7 layers and it provides foundation to this
network operating system. WINDGate,Cisco IOS,BSD are some of the example of NOS.

 Distributed Operating System: Distributed systems are located in geographical areas and it is
comprised of collection of processors.In Distributed OS the task is divided among different
processors that communicate using telephone lines or buses.In this the processors do not share
resources such as CPUs, memories, peripheral devices, the network, and data of all kinds instead
of this they have their own local memory.For Example- Amoeba,Angle,Chorus,Mach.

 Multi user operating system: In this case various users can perform different tasks on the
computer.Well if you have made multiple accounts on the windows operating system it doesn’t
make it multi user operating system.It is still a single user operating system.The main disadvantage
is if multiple users are using the system then it decreases the performance of the system.For
example- UNIX,Windows 2000,Novell Netware

 Embedded System: The operating systems designed for being used in embedded computer
systems are known as embedded operating systems. They are designed for small machines.They
have limited number of resources and are very compact and extremely efficient by design.

 Mobile Operating System: Nowdays android is being used in mobiles as an operating
system.Android is a linux based mobile platform operating system and it is developed by google.
Tablet PCs and smartphones run on mobile operating systems. Ex: Android OS, Blackberry OS, and
Apple’s iOS are some of the most known names of mobile operating systems.

Working knowledge of GUI based operating system

Graphical User Interface, a GUI (pronounced as either G-U-I or gooey) allows the use of icons or other
visual indicators to interact with electronic devices, rather than using only text via the command line. For
example, all versions of Microsoft Windows utilize a GUI, whereas MS-DOS does not. The GUI was first
developed at Xerox PARC by Alan Kay, Douglas Engelbart, and a group of other researchers in 1981.
Later, Apple introduced the Lisa computer, the first commercially available computer, on January
19, 1983. Below is a picture of the Windows 7 Desktop and an example of a GUI.

How does a GUI work?
A GUI uses windows, icons, and menus to carry out commands, such as opening, deleting, and moving
files. Although many GUI operating systems are navigated through the use of a mouse, the keyboard can
also be utilized by using keyboard shortcuts or arrow keys.



What are the benefits of GUI?
Unlike a command line operating system or CUI, like Unix or MS-DOS, GUI operating systems are much
easier to learn and use because commands do not need to be memorized. Additionally, users do not need
to know any programming languages.
Because of their ease of use, GUI
operating systems have become the
dominant operating system used by
today's end-users.

What are examples of a GUI operating
system?
 Microsoft Windows
 Apple System 7 and macOS
 Chrome OS
 Linux variants like Ubuntu

Are all operating systems GUI?
No. Early command line operating
systems like MS-DOS and even some versions of Linuxtoday have no GUI interface.

What are examples of a GUI interface?
 GNOME
 KDE
 Any Microsoft program (i.e. Word, Excel, Outlook)
 Internet browser (i.e. Internet Explorer, Chrome, Firefox)

How does the user interact with a GUI?
Typically the user uses a pointing device such as the mouse to interact and use most aspects of the GUI.
However, it is also possible to interact with a GUI using a keyboard or other input device.

Introduction to word processors and its features

Word Processing is using a computer to create, edit, and print documents. Of all computer applications,
word processing is the most commonly used. To perform word processing, a computer, a special program
called a word processor and a printer are required. A word processor enables the user to create a
document, store it electronically on a USB or on a computer, display it on a screen, modify or format it by
entering commands and characters from the keyboard, and print it on a printer.

What Application Software is Available?
Microsoft Word is the most widely used word processing software. Microsoft estimates that over
500,000,000 people use the Microsoft Office suite, which includes Word. Many other word processing
applications exist, including WordPerfect and open source applications OpenOffice.org Writer, LibreOffice
Writer, AbiWord, KWord, and LyX. Web-based word processors, such as Office Web Apps or Google Docs,
are a relatively new category of application software.

Most Word processors support additional advanced features in addition to the basic features provided by
the text editors. They enable you for creating and editing high quality documents. These advanced Word
processors are sometimes called Full-Featured Word Processors. Microsoft Word is one of the most
popular Full-Featured Word Processor.

What are the benefits of GUI?
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Features of Full Featured Word Processors

 File Management: Many Word processors contain file management capabilities that allow the
user to create, delete, move, and search files.

 Font Specifications: This feature allows you to change fonts within a document. For example, a
user can specify bold, italics, and underlining. Most Word processors also allow the user to change
the font size and the typeface.

 Footnotes & Cross-References: This feature allows the user to add footnotes in a document. A
footnotes is added at bottom of the page. The Word processor also enables you to easily cross-
reference other sections of the document.

 Graphics: This feature allows the user to insert pictures and graphs into a document. Some Word
processors also provide facility to create and edit the pictures and graphics within the document.
However, some Word processors provide facility to insert pictures created in different graphics
programs.

 Headers & Footers:
 This feature allows the user to specify information for header and footers.
 Header is the information that is printed in the top of each page of the document.
 Footer is the information that is printed in the bottom of each page of the document.

 Page Numbering: The Word processor automatically keeps track of page numbers so that the
correct number appears on each page.

 Layout: This feature allows the user to specify page sizes, margins, indents, line spacing within a
document.

 Macros: You can create macros in full-features word processor. A macro is a small code. It
represents a series of keystrokes or commands. Usually, a single key is assigned to a macro. All
commands in a macro are executed when a key assigned to a macro is pressed.

 Mail Merge: The most important feature of Word processor is the mail-merge, in which the
records of a database can be merged into the document. It is a very shortcut method used to
create form letters, mailing labels, envelopes etc. For example to send result cards to all the
students of a college, the mail-merge method is used.

 Spell Checker: This feature allows the user to check incorrect spelling of words in the document
and correct these incorrect words. It highlights the misspelled word. It is noted that most of the
word processors have built-in-dictionary.

 Thesaurus: Thesaurus means vocabulary. Microsoft Word has a complete dictionary. The user can
select a simple word for a difficult word from a list of altemate words.

 Tables Contents and Indexes: This feature allows the user to automatically create a table of
contents and index based on special codes that you insert in the document.

 Document Windows: This feature allows the user to edit two or more documents at the same
time. Each document appears in a separate windows. This is particularly valuable where working
on a large project that consists of several different document files.

 WYSIWYG: WYSIWYG stands for What You See Is What You Get. It means that printout of
document will be similar as appears on the display screen.

 Creating, editing, printing and saving documents.
 Ctrl + N – for creating new document
 Ctrl + P – for printing document
 Ctrl + S – for saving document



Mail merge

Mail merge is used to create multiple documents at once. These documents have identical layout,
formatting, text, and graphics. Only specific sections of each document varies and is personalized. The
documents Word can create with mail merge include bulk labels, letters, envelopes, and emails. There are
three documents involved in the mail merge process:
 Your main document
 Your data source
 Your merged document

Step 1: Prepare data in Excel for mail merge
You'll use your Excel spreadsheet as the data source for the recipient list. Make sure:
 Column names in your spreadsheet match the field names you want to insert in your mail merge.

For example, to address readers by their first name in your document, you'll need separate
columns for first and last names.

 All data to be merged is present in the first sheet of your spreadsheet.
 Data entries with percentages, currencies, and postal codes are correctly formatted in the

spreadsheet so that Word can properly read their values.
 The Excel spreadsheet to be used in the mail

merge is stored on your local machine.
 Changes or additions to your spreadsheet are

completed before it's connected to your mail
merge document in Word.

Step 2: Start the mail merge
 In Word, choose File > New > Blank document.
 On the Mailings tab, in the Start Mail

merge group, choose Start Mail Merge, and then
choose the kind of merge you want to run.

 Choose Select Recipients > Use an Existing List.
 Browse to your Excel spreadsheet, and then

choose Open.
 If Word prompts you, choose Sheet1$ > OK.

Edit your mailing list
You can limit who receives your mail.
 Choose Edit Recipient List.
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 In the Mail Merge Recipients dialog box, clear the check box next to the name of any person who
you don't want to receive your mailing.

.

Step 3: Insert a merge field
You can insert one or more mail merge fields that pull the information from your spreadsheet into your
document. To insert an address block for an
envelope, a label, an email message, or a letter
 On the Mailings tab, in the Write & Insert

Fields group, choose Address Block.
 In the Insert Address Block dialog box,

choose a format for the recipient's name as
it will appear on the envelope.

Choose OK.
 Choose File > Save.

To insert a greeting line in an email message or a
letter
 On the Mailings tab, in the Write & Insert

Fields group, choose Greeting Line.

In the Insert Greeting Line dialog box, do the following:

 Under Greeting line format, change the salutation if necessary by choosing the greeting (Dear is
the default), the format for the recipient name, and the ending punctuation (a comma is the
default).

 Under Greeting line for invalid recipient names, choose an option in the salutation list.
 Choose OK.
 Choose File > Save.

 In the Mail Merge Recipients dialog box, clear the check box next to the name of any person who
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.
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To insert data from your spreadsheet in an email message or a letter
 On the Mailings tab, in the Write & Insert Fields group, choose Insert Merge Field.
 In the Insert Merge Field dialog box, under Fields, choose a field name (column name in your

spreadsheet), and then choose Insert.
 Repeat step 2 as needed, and choose Close when done.
 Choose File > Save.

For more information about adding fields from your spreadsheet to the merge document, see Insert mail
merge fields. And if you're interested in learning more about options for setting up email message,
see Email merge in Word.

Step 4: Preview and finish the mail merge
After you insert the merge fields you want, preview
the results to confirm that the content is okay. and
then you're ready to complete the merge process.
 On the Mailings tab, choose Preview Results.
 Choose the Next or Previous record

button to move through records in your data source and view how the records will appear in the
document.

 In the Finish group, choose Finish & Merge, and choose Print Documents or Send E-mail Messages.

Step 5: Save your mail merge

 When you save the mail merge document, it
stays connected to your data source. You can
reuse the mail merge document for your next
bulk mailing.
 Open the mail merge document and

choose Yes when Word prompts you to keep the
connection.

Creating power point presentations

PowerPoint presentations work like slide shows. To convey a message or a story, you break it down into
slides. Think of each slide as a blank canvas for the pictures, words, and shapes that will help you build
your story.

Choose a theme
When you open PowerPoint, you’ll see some built-in themes and templates. A theme is a slide design that
contains matching colors, fonts, and special effects like shadows, reflections, and more.
 Choose a theme.
 Click Create, or pick a color variation and then click Create.
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Insert a new slide
 On the Home tab, click New Slide, and pick a slide

layout.

Save your presentation
 On the File tab, choose Save.
 Pick or browse to a folder.
 In the File name box, type a name for your

presentation, and then choose Save.

Add text

 Select a text placeholder, and begin typing.

Format your text
 Select the text.
 Under Drawing Tools, choose Format.
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 Do one of the following:
 To change the color of your text, choose Text Fill, and then choose a color.
 To change the outline color of your text, choose Text Outline, and then choose a color.
 To apply a shadow, reflection, glow, bevel, 3-D rotation, a transform, choose Text Effects, and then

choose the effect you want.

Add pictures

On the Insert tab, do one of the following:

 To insert a picture that is saved on your local drive or an internal server, choose Pictures, browse
for the picture, and then choose Insert.

 To insert a picture from the Web, choose Online Pictures, and use the search box to find a picture.

 Choose a picture, and then click Insert.

Give your presentation

On the Slide Show tab, do one of the following:
 To start the presentation at the first slide, in the Start Slide Show group, click From Beginning.
 If you’re not at the first slide and want to start from where you are, click From Current Slide.
 If you need to present to people who are not where you are, click Present Online to set up a

presentation on the web, and then choose one of the following options:

Get out of Slide Show view

 To get out of Slide Show view at any time, on the keyboard, press Esc.
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Creating spreadsheets and simple graphs

Excel is a great program to use for making and editing spreadsheets, but it can also be used to quickly
produce some professional graphs. Excel graphs aren’t extremely detailed, but they are a solid way to add
easy-to-read data to any presentation or report.

Step 1- Enter information into a spreadsheet. Columns will be vertical on the graph and rows will be
horizontal.

Step 2- Highlight the cells you want to graph.

Step 3- Go to Insert, then Chart.
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Step 4- Choose the kind of graph you want to use. Your choice largely depends on what you’ll be using the
graph for and what kind of information you have. To compare how things have changed over time, a line
graph may be ideal. To display growth, a bar or column graph works nicely. Evaluate your information and
how you want to present it.

Step 5- At this point, you have a basic chart. Now it’s time to spruce it up a bit. Add a title by clicking the
“Chart Title” box at the top. You can change the colors using the options at the top, name each axis, and
move or change the legend, which is located at the bottom. The goal is simply to make it very clear to
read. A good graph is useless if it can’t be understood easily.

Evolution of Internet

The concept of Internet was originated in 1969 and has undergone several technological & Infrastructural
changes as discussed below:
 The origin of Internet devised from the concept of Advanced Research Project Agency Network

(ARPANET).
 ARPANET was developed by United States Department of Defence.
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 Basic purpose of ARPANET was to provide communication among the various bodies of
government.

 Initially, there were only four nodes, formally called Hosts.
 In 1972, the ARPANET spread over the globe with 23 nodes located at different countries and thus

became known as Internet.
 By the time, with invention of new technologies such as TCP/IP protocols, DNS, WWW, browsers,

scripting languages etc., Internet provided a medium to publish and access information over the
web.

Applications and services of Internet

The Internet is a global system of interconnected computer networks that use the standard Internet
Protocol Suite (TCP/IP) to serve billions of users worldwide. It is a network of networks that consists of
millions of private, public, academic, business, and government networks, of local to global scope, that
are linked by a broad array of electronic and optical networking technologies. The Internet carries a vast
range of information resources and services, such as the inter-linked hypertext documents of the World
Wide Web (WWW) and the infrastructure to support electronic mail.

Applications:
 Search engine: It can be used to search anything and everything. Most popular search engines are

Google and yahoo searches.
 Shopping: Shopping has become easier with the advent of internet. You can buy or sell online.
 Communication: This is a major role of the internet. It helps people to communicate either with

the use of social networking websites or through e mails. Even chatting is a major use of the
internet.

 Job search: Nowadays, many people search for their jobs online as it is quicker and there is a
larger variety of job vacancies present.

 Hobbies: Those who are having certain hobbies can try to improve on it by reading up on many
aspects of their hobby.

 Research: Research papers are present online which helps in the researcher doing a literature
review.

 Studying: Now right from kinder garden children are exposed to internet and computers.). Up to
doctorate level education, people rely on internet for their education. Online educational books
have even reduced the need for a library

Internet Services allows us to access huge amount of information such as text, graphics, sound and
software over the internet. Following diagram shows the four different categories of Internet Services.

 Basic purpose of ARPANET was to provide communication among the various bodies of
government.

 Initially, there were only four nodes, formally called Hosts.
 In 1972, the ARPANET spread over the globe with 23 nodes located at different countries and thus

became known as Internet.
 By the time, with invention of new technologies such as TCP/IP protocols, DNS, WWW, browsers,

scripting languages etc., Internet provided a medium to publish and access information over the
web.

Applications and services of Internet

The Internet is a global system of interconnected computer networks that use the standard Internet
Protocol Suite (TCP/IP) to serve billions of users worldwide. It is a network of networks that consists of
millions of private, public, academic, business, and government networks, of local to global scope, that
are linked by a broad array of electronic and optical networking technologies. The Internet carries a vast
range of information resources and services, such as the inter-linked hypertext documents of the World
Wide Web (WWW) and the infrastructure to support electronic mail.

Applications:
 Search engine: It can be used to search anything and everything. Most popular search engines are

Google and yahoo searches.
 Shopping: Shopping has become easier with the advent of internet. You can buy or sell online.
 Communication: This is a major role of the internet. It helps people to communicate either with

the use of social networking websites or through e mails. Even chatting is a major use of the
internet.

 Job search: Nowadays, many people search for their jobs online as it is quicker and there is a
larger variety of job vacancies present.

 Hobbies: Those who are having certain hobbies can try to improve on it by reading up on many
aspects of their hobby.

 Research: Research papers are present online which helps in the researcher doing a literature
review.

 Studying: Now right from kinder garden children are exposed to internet and computers.). Up to
doctorate level education, people rely on internet for their education. Online educational books
have even reduced the need for a library

Internet Services allows us to access huge amount of information such as text, graphics, sound and
software over the internet. Following diagram shows the four different categories of Internet Services.

 Basic purpose of ARPANET was to provide communication among the various bodies of
government.

 Initially, there were only four nodes, formally called Hosts.
 In 1972, the ARPANET spread over the globe with 23 nodes located at different countries and thus

became known as Internet.
 By the time, with invention of new technologies such as TCP/IP protocols, DNS, WWW, browsers,

scripting languages etc., Internet provided a medium to publish and access information over the
web.

Applications and services of Internet

The Internet is a global system of interconnected computer networks that use the standard Internet
Protocol Suite (TCP/IP) to serve billions of users worldwide. It is a network of networks that consists of
millions of private, public, academic, business, and government networks, of local to global scope, that
are linked by a broad array of electronic and optical networking technologies. The Internet carries a vast
range of information resources and services, such as the inter-linked hypertext documents of the World
Wide Web (WWW) and the infrastructure to support electronic mail.

Applications:
 Search engine: It can be used to search anything and everything. Most popular search engines are

Google and yahoo searches.
 Shopping: Shopping has become easier with the advent of internet. You can buy or sell online.
 Communication: This is a major role of the internet. It helps people to communicate either with

the use of social networking websites or through e mails. Even chatting is a major use of the
internet.

 Job search: Nowadays, many people search for their jobs online as it is quicker and there is a
larger variety of job vacancies present.

 Hobbies: Those who are having certain hobbies can try to improve on it by reading up on many
aspects of their hobby.

 Research: Research papers are present online which helps in the researcher doing a literature
review.

 Studying: Now right from kinder garden children are exposed to internet and computers.). Up to
doctorate level education, people rely on internet for their education. Online educational books
have even reduced the need for a library

Internet Services allows us to access huge amount of information such as text, graphics, sound and
software over the internet. Following diagram shows the four different categories of Internet Services.



Internet provides a lot of services. Few of them are described below:

 World Wide Web (WWW)
 E-Mail
 Telnet
 File Transfer Protocol (FTP)
 Gopher
 Chat Groups

 World Wide Web (WWW): The World Wide Web is commonly known as web. It is a network of
web servers that stores web pages. The web pages are connected to each other using hyperlinks.
The user can jump from one page to another by clicking the hyperlinks. The web web pages are
accessed using web browsers. The HTTP (Hyper Text Transfer Protocol) protocol is used for
communication between browser and web servers.

 E-Mail: E-mail stands for electronic email. It is the most popular service provided by the Internet.
It provides the fast and efficient way to send and receive messages through Internet. One message
can be sent to many persons with a single e-mail. Different types of files can also be sent through
e-mail.

 Telnet: Telnet is an abbreviation for Terminal Network. It is a software. It is used to connect to a
remote or host computer for accessing information. Through this service, the user can also access
information on the Internet.
When a user runs this software on his/her computer, it provides a prompt on the user's computer
screen. The user can access the host computer by giving commands through this prompt. When a
command is sent to the host computer, information is accessed from host and displayed on user's
computer screen. The user's computer linked to the remote computer will act as a terminal. The
expert users mostly use this service. In some remote servers, this service is not allowed.

 File Transfer Protocol (FTP): FTP stands for File Transfer Protocol. It is a way for transferring files
from one computer to another. The process of transferring a file from a server (or remote
computer) to local computer is called downloading. Similarly, the process for transferring a file
from local computer to the server on the Internet is called uploading.
Different FTP client programs are available for uploading and downloading files to and from the
server. The most commonly used FTP client programs are WS_FTP and Cute FTP.

 Gopher: A gopher is a menu-based information retrieval system. It is used for retrieving files and
programs on the Internet. Gopher allows access to files found on FTP servers and web servers.

 Chat Groups: Internet provides the facility to Internet users to chat (talk) with people online all
over the world. Different programs like MSN Messenger, Yahoo Messenger, AOL online etc. are
available for chatting on the Internet. Chat rooms allow the users to participate in a chat on the
Internet. Chat rooms on are locations on the web that provide facilities to the users to chat with
each other online over the Internet. They send messages by typing with keyboard and receive
messages from other end instantly. Some chat rooms support voice chats and video chats where
people talk with each other and see them also.


